summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 00:39:17 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-19 23:32:33 +0000
commit92b5c13c6ad16cebb2c92c41fac3c86138749b86 (patch)
tree843be49e14245e232440cc39761dd1f09dc9ef5f /gnu/packages
parentefa4809384e4b82395818431b1d37a0dbfe89ba5 (diff)
downloadguix-92b5c13c6ad16cebb2c92c41fac3c86138749b86.tar.gz
gnu: go-github-com-songmu-gitconfig: Fix build.
As seen in <https://ci.guix.gnu.org/build/3490304/log/raw>.

* gnu/packages/golang-xyz.scm go-github-com-songmu-gitconfig: Update
style.
[arguments] <#:go>: Use go-1.21.

Change-Id: Iea7a32b51d4bd74e99c52938307c11177ae79199
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ff62b83995..e68948e495 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1153,10 +1153,12 @@ Use waterutil with it to work with TUN/TAP packets/frames.")
         (base32 "1y01h496a7pfj1g2bclls5b0nl3vnj7nz610jj1dzq9kxrwxk7fk"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "github.com/Songmu/gitconfig"
-       ;; Package's tests appear to be hardcoded to the author's gitconfig
-       ;; and require network access.
-       #:tests? #f))
+     (list
+      ;; Package's tests appear to be hardcoded to the author's gitconfig
+      ;; and require network access.
+      #:tests? #f
+      #:go go-1.21
+      #:import-path "github.com/Songmu/gitconfig"))
     (propagated-inputs
      (list go-github-com-goccy-yaml))
     (synopsis "Go library to get configuration values from gitconfig")