summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:15:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:33 +0200
commit92c776ce7fcfe7e48437d01f04e48383ab4a4d0b (patch)
treef37bc341702bd078c0df296c632cc13be75d1814 /gnu/packages
parentbde8219ef80f4158ee9ffd586e078016658141f9 (diff)
downloadguix-92c776ce7fcfe7e48437d01f04e48383ab4a4d0b.tar.gz
gnu: Add texlive-pst-diffraction.
* gnu/packages/tex.scm (texlive-pst-diffraction): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4a7769e14c..5c85abff0d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32780,6 +32780,33 @@ positioning some nodes and defining the position of all other nodes relative
 to them by using the standard database terminology.")
     (license license:lppl)))
 
+(define-public texlive-pst-diffraction
+  (package
+    (name "texlive-pst-diffraction")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/pst-diffraction/"
+                   "source/generic/pst-diffraction/"
+                   "tex/generic/pst-diffraction/"
+                   "tex/latex/pst-diffraction/")
+             (base32
+              "1wi67md3046nj0arqi1wmbgdhdrsnfqgmmb0ayk2iswfhvx32myr")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pst-diffraction")
+    (synopsis "Print diffraction patterns from various apertures")
+    (description
+     "The package enables the user to draw (using PSTricks) the diffraction
+patterns for different geometric forms of apertures for monochromatic light.
+The aperture stops can have rectangular, circular or triangular openings.  The
+view of the diffraction may be planar, or three-dimensional.  Options
+available are the dimensions of the aperture under consideration and of the
+particular optical setting, e.g., the radius in case of an circular opening.
+Moreover one can choose the wavelength of the light (the associated color will
+be calculated by the package).")
+    (license license:lppl)))
+
 (define-public texlive-pst-text
   (package
     (name "texlive-pst-text")