summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:58:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:26 +0200
commit92d75955a3ee4337ae9726fada2c377a680c8b8c (patch)
tree206ff9cd34157730ce92fe488b2be4355fb0c8d7 /gnu/packages
parentf3c0d2f8606779c655b655e453b427d0714d6c2f (diff)
downloadguix-92d75955a3ee4337ae9726fada2c377a680c8b8c.tar.gz
gnu: Add texlive-luaprogtable.
* gnu/packages/tex.scm (texlive-luaprogtable): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c9f8fe2a35..b2c6c7cd2c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16764,6 +16764,25 @@ arguments into proper Lua tables.")
 to load external Lua modules, including modules installed via LuaRocks.")
     (license license:lppl1.3c)))
 
+(define-public texlive-luaprogtable
+  (package
+    (name "texlive-luaprogtable")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/lualatex/luaprogtable/"
+                   "tex/lualatex/luaprogtable/")
+             (base32
+              "0vx4vsqa777hv4bdw8m7x8hrjg5p9h8d68z0l2ji60h67bziy161")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/luaprogtable")
+    (synopsis "Programmable table interface for LuaLaTeX")
+    (description
+     "This package allows you to modify a cell based on the contents of other
+cells using LaTeX macros.")
+    (license license:expat)))
+
 (define-public texlive-babel-czech
   (package
     (name "texlive-babel-czech")