summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-23 10:14:59 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-30 09:08:05 +0100
commit9408fa3754a6a445fb54cddb03368b6685a24d5a (patch)
treefcda3d4e4dbb0c80e49e9b8812fed9cc222f4eb8 /gnu/packages
parent79d95394c0937d5bf1cebb0c7b941c5ecb1a73a9 (diff)
downloadguix-9408fa3754a6a445fb54cddb03368b6685a24d5a.tar.gz
gnu: Add mapbox-variant.
* gnu/packages/cpp.scm (mapbox-variant): New variable.

Change-Id: Id84b35d97d73fcf1c116ddca844bc75ada627b55
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cpp.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 5e35a03254..2b32a2becf 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2802,6 +2802,43 @@ Main features:
 @end itemize")
     (license license:expat)))
 
+(define-public mapbox-variant
+  (package
+    (name "mapbox-variant")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mapbox/variant")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "03cmxm34ralh8y07bs80gz3v4pql51206dn5h7lcnm7vishkk241"))
+              (modules '((guix build utils)))
+              (snippet #~(begin
+                           (delete-file "test/include/catch.hpp")
+                           (substitute* (find-files "test" "\\.[ch]pp")
+                             (("\"catch.hpp\"") "<catch/catch.hpp>"))))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:test-target "test"
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'bootstrap)
+               (delete 'configure)
+               (delete 'build)
+               (replace 'install
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (copy-recursively "include"
+                                     (string-append (assoc-ref outputs "out")
+                                                    "/include")))))))
+    (native-inputs (list catch2-1))
+    (home-page "https://github.com/mapbox/variant")
+    (synopsis "Implementation of std::variant for C++11/14")
+    (description "This package provides a header-only implementation of
+std::variant (formerly boost::variant) for C++11/14.")
+    (license license:bsd-3)))
+
 (define-public mpark-variant
   (package
     (name "mpark-variant")