summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorChristopher Lemmer Webber <cwebber@dustycloud.org>2019-06-08 22:37:50 -0400
committerChristopher Lemmer Webber <cwebber@dustycloud.org>2019-06-11 13:45:27 -0400
commit948ecc27dd33d6c9bd77e06c82b49e5a1139868b (patch)
treedf13f7102bd11a8c8bde4b5edf9801a94905a360 /gnu/packages
parent944cb87a33e222cacae6647f37325b94e6a47568 (diff)
downloadguix-948ecc27dd33d6c9bd77e06c82b49e5a1139868b.tar.gz
gnu: racket: Update to 7.3.
* gnu/packages/scheme.scm (racket): Update to 7.3.
* gnu/packages/patches/racket-store-checksum-override.patch: Update for Racket
  7.3.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/racket-store-checksum-override.patch35
-rw-r--r--gnu/packages/scheme.scm4
2 files changed, 16 insertions, 23 deletions
diff --git a/gnu/packages/patches/racket-store-checksum-override.patch b/gnu/packages/patches/racket-store-checksum-override.patch
index 6c9cd5198a..236c843de1 100644
--- a/gnu/packages/patches/racket-store-checksum-override.patch
+++ b/gnu/packages/patches/racket-store-checksum-override.patch
@@ -7,12 +7,8 @@ because the store is immutable.  This patch makes Racket ignore
 checksums for files in the store.
 
 See <https://debbugs.gnu.org/30680> for details.
----
- collects/compiler/private/cm-minimal.rkt | 8 +++++++-
- 1 file changed, 7 insertions(+), 1 deletion(-)
 
-diff --git a/collects/compiler/private/cm-minimal.rkt b/collects/compiler/private/cm-minimal.rkt
-index a5a5407..15af6b8 100644
+---
 --- a/collects/compiler/private/cm-minimal.rkt
 +++ b/collects/compiler/private/cm-minimal.rkt
 @@ -7,6 +7,7 @@
@@ -20,10 +16,10 @@ index a5a5407..15af6b8 100644
           racket/path
           racket/promise
 +         racket/string
-          openssl/sha1
+          file/sha1
           setup/collects
-          compiler/compilation-path
-@@ -543,6 +544,10 @@
+          setup/cross-system
+@@ -940,6 +941,10 @@
        #f
        (list src-hash recorded-hash)))
  
@@ -34,16 +30,13 @@ index a5a5407..15af6b8 100644
  (define (rkt->ss p)
    (if (path-has-extension? p #".rkt")
        (path-replace-extension p #".ss")
-@@ -595,7 +600,8 @@
-               (trace-printf "newer src... ~a > ~a" path-time path-zo-time)
-               ;; If `sha1-only?', then `maybe-compile-zo' returns a #f or thunk:
-               (maybe-compile-zo sha1-only? deps path->mode roots path orig-path read-src-syntax up-to-date collection-cache new-seen)]
--             [(different-source-sha1-and-dep-recorded path deps)
-+             [(and (not (store-reference? path))
-+                   (different-source-sha1-and-dep-recorded path deps))
-               => (lambda (difference)
-                    (trace-printf "different src hash... ~a" difference)
-                    ;; If `sha1-only?', then `maybe-compile-zo' returns a #f or thunk:
--- 
-2.18.0
-
+@@ -1015,6 +1020,7 @@
+                (trace-printf "newer src... ~a > ~a" path-time path-zo-time)
+                (maybe-compile-zo deps path->mode roots path orig-path read-src-syntax up-to-date collection-cache new-seen
+                                  #:trying-sha1? sha1-only?)]
+-              [(different-source-sha1-and-dep-recorded path deps)
++              [(and (not (store-reference? path))
++                    (different-source-sha1-and-dep-recorded path deps))
+                => (lambda (difference)
+                     (trace-printf "different src hash ~a for ~a..." difference path)
+                     (maybe-compile-zo deps path->mode roots path orig-path read-src-syntax up-to-date collection-cache new-seen
\ No newline at end of file
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 3e5ab72f20..9962cbdcb5 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -437,7 +437,7 @@ implementation techniques and as an expository tool.")
 (define-public racket
   (package
     (name "racket")
-    (version "7.0")
+    (version "7.3")
     (source (origin
               (method url-fetch)
               (uri (list (string-append "http://mirror.racket-lang.org/installers/"
@@ -447,7 +447,7 @@ implementation techniques and as an expository tool.")
                           version "/racket-" version "-src.tgz")))
               (sha256
                (base32
-                "1glv5amsp9xp480d4yr63hhm9kkyav06yl3a6p489nkr4cln0j9a"))
+                "0h6072njhb87rkz4arijvahxgjzn8r14s4wns0ijvxm89bg136yl"))
               (patches (search-patches
                         "racket-store-checksum-override.patch"))))
     (build-system gnu-build-system)