summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-31 13:15:31 -0500
committerLeo Famulari <leo@famulari.name>2018-01-03 12:30:14 -0500
commit990e93fce16a83e1603b9ec28123ec3edc7ea787 (patch)
tree5133e89e24cb06f6a5ede16752369d04730c5310 /gnu/packages
parented8bdde9ced0e08cee898d38d13af02b249d44f1 (diff)
downloadguix-990e93fce16a83e1603b9ec28123ec3edc7ea787.tar.gz
gnu: krita: Ensure icons are found at runtime.
Fixes <https://bugs.gnu.org/29905>.

* gnu/packages/kde.scm (krita)[arguments]: Set the QT_PLUGIN_PATH in a
new 'wrap-executable' phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 94834c336c..fdfca94e21 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -260,7 +260,21 @@ plugins, as well as code to create plugins, or complete applications.")
                             (assoc-ref %build-inputs "libtiff"))
              (string-append "-DCMAKE_CXX_FLAGS=-I"
                             (assoc-ref %build-inputs "ilmbase")
-                            "/include/OpenEXR"))))
+                            "/include/OpenEXR"))
+       #:phases
+       (modify-phases %standard-phases
+         ;; Ensure that icons are found at runtime
+         (add-after 'install 'wrap-executable
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (qt '("qtbase" "qtsvg")))
+               (wrap-program (string-append out "/bin/krita")
+                 `("QT_PLUGIN_PATH" ":" prefix
+                   ,(map (lambda (label)
+                           (string-append (assoc-ref inputs label)
+                                          "/lib/qt5/plugins/"))
+                         qt)))
+               #t))))))
     (native-inputs
      `(("curl" ,curl)
        ("eigen" ,eigen)