summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-02 10:14:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-02 10:14:37 +0200
commit9bb428ad681bd2f779dd52db41d0f4112efab912 (patch)
tree5669c48ff980859f9bc782d482b89197afb35e84 /gnu/packages
parent62ed97c07d83f58fb051a77b6d3b79b54e579e09 (diff)
downloadguix-9bb428ad681bd2f779dd52db41d0f4112efab912.tar.gz
gnu: Add r-microbiomestat.
* gnu/packages/bioconductor.scm (r-microbiomestat): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 31bd4e24b0..75605945ae 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -12174,6 +12174,40 @@ format and expands the available toolkit in order to facilitate the
 standardization of the analyses and the development of best practices.")
     (license license:bsd-2)))
 
+;; This is a CRAN package but it depends on phyloseq, which is from
+;; Bioconductor.
+(define-public r-microbiomestat
+  (package
+    (name "r-microbiomestat")
+    (version "1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "MicrobiomeStat" version))
+              (sha256
+               (base32
+                "1j5sar85a1gksc83pc4ypxwb0c7whxglx069zarphrgqfazcr1m4"))))
+    (properties `((upstream-name . "MicrobiomeStat")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-foreach
+                             r-ggplot2
+                             r-ggrepel
+                             r-lmertest
+                             r-mass
+                             r-matrix
+                             r-matrixstats
+                             r-modeest
+                             r-phyloseq
+                             r-statmod))
+    (home-page "https://cran.r-project.org/package=MicrobiomeStat")
+    (synopsis "Statistical methods for microbiome compositional data")
+    (description
+     "This package provides a suite of methods for powerful and robust
+microbiome data analysis addressing zero-inflation, phylogenetic structure and
+compositional effects.  The methods can be applied to the analysis of
+other (high-dimensional) compositional data arising from sequencing
+experiments.")
+    (license license:gpl3)))
+
 (define-public r-milor
   (package
     (name "r-milor")