summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:37:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-20 17:37:55 +0300
commit9c2e6516622d19ca2e484e2c168a1f94f2c96f76 (patch)
tree8b6a8193d18d89e196b03105b86c691dc5e3fafc /gnu/packages
parent6de5b0f03dbbf47d3d632d175e0abc283c673bbe (diff)
downloadguix-9c2e6516622d19ca2e484e2c168a1f94f2c96f76.tar.gz
gnu: python-zope-schema: Update to 6.0.0.
* gnu/packages/python-web.scm (python-zope-schema): Update to 6.0.0.
[arguments]: Don't skip tests. Use custom 'check phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 02bd3fe58f..8a21895228 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1240,17 +1240,24 @@ internationalized messages within program source text.")
 (define-public python-zope-schema
   (package
     (name "python-zope-schema")
-    (version "5.0.1")
+    (version "6.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "zope.schema" version))
        (sha256
         (base32
-         "0q93j0x52a42khw12al90jw2bk0wly3jwghql3a25zpwwxvn24ya"))))
+          "09jg47bxhfg1ahr1jxb5y0cbiszyk1j6fn1r1r7s6svjl3lbryr0"))))
     (build-system python-build-system)
     (arguments
-     '(#:tests? #f)) ; FIXME: Tests can't find zope.event.
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (add-installed-pythonpath inputs outputs)
+             (if tests?
+               (invoke "zope-testrunner" "--test-path=src")
+               #t))))))
     (propagated-inputs
      `(("python-zope-event" ,python-zope-event)
        ("python-zope-interface" ,python-zope-interface)))