summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-17 18:48:04 +0200
committerMarius Bakke <marius@gnu.org>2022-09-18 10:35:38 +0200
commit9e256a05f240a8fb28ceaf8095edc07c9465c0f6 (patch)
tree9cf75a2e662f3651ec774dd8ad624f76babea08e /gnu/packages
parent267604449e267e81c11fb222d0de4de4c0a80bec (diff)
downloadguix-9e256a05f240a8fb28ceaf8095edc07c9465c0f6.tar.gz
gnu: shepherd: Promote 0.9 to the default.
* gnu/packages/admin.scm (shepherd-0.9): Inherit from SHEPHERD-0.8.
(shepherd): Alias to SHEPHERD-0.9.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/admin.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 7bc6f67ded..2609ae3831 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -319,12 +319,9 @@ interface and is based on GNU Guile.")
     (license license:gpl3+)
     (home-page "https://www.gnu.org/software/shepherd/")))
 
-;; Update on the next rebuild cycle.
-(define-public shepherd shepherd-0.8)
-
 (define-public shepherd-0.9
   (package
-    (inherit shepherd)
+    (inherit shepherd-0.8)
     (version "0.9.2")
     (source (origin
               (method url-fetch)
@@ -367,6 +364,8 @@ interface and is based on GNU Guile.")
                          guile-fibers-1.1))       ;for cross-compilation
     (inputs (list guile-3.0 guile-fibers-1.1))))
 
+(define-public shepherd shepherd-0.9)
+
 (define-public guile2.2-shepherd
   (package
     (inherit shepherd-0.9)