summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 00:09:05 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:31 +0200
commit9f1b0e9af06b7608174847f91e42358e9ee66ea8 (patch)
tree8687ed01cc711a920b01d1f1e5b6df955f58eb36 /gnu/packages
parent42813018f3c13d2419cc7260f7b78ed81d8a164c (diff)
downloadguix-9f1b0e9af06b7608174847f91e42358e9ee66ea8.tar.gz
gnu: Add texlive-isodate.
* gnu/packages/tex.scm (texlive-isodate): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 23b7c83667..cb6f1d0286 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17676,6 +17676,30 @@ International Conference on Information Systems for Crisis Response and
 Management}.")
     (license license:lppl1.3+)))
 
+(define-public texlive-isodate
+  (package
+    (name "texlive-isodate")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/isodate/" "source/latex/isodate/"
+                   "tex/latex/isodate/")
+             (base32
+              "0bha4qpa1hi5i4npr00wz4qvzzc4yw4qydjjmm8n878p8cfygvga")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/isodate")
+    (synopsis "Tune the output format of dates according to language")
+    (description
+     "This package provides ten output formats of the commands @code{\\today},
+@code{\\printdate}, @code{\\printdateTeX}, and @code{\\daterange} (partly
+language dependent).  The commands @code{\\printdate} and
+@code{\\printdateTeX} print any date.  The command @code{\\daterange} prints
+a date range and leaves out unnecessary year or month entries.  This package
+supports German (old and new rules), Austrian, US English, British English,
+French, Danish, Swedish, and Norwegian.")
+    (license license:lppl)))
+
 (define-public texlive-isomath
   (package
     (name "texlive-isomath")