summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-04 21:57:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:14 +0200
commit9f61f47746eda9ee45c135d04ec7f2e4479d8629 (patch)
tree5a50e8efc0642a1d3e1158be1247ee8f6914bbe6 /gnu/packages
parent1c5299aa40791c1507706ba756e3f130205e1787 (diff)
downloadguix-9f61f47746eda9ee45c135d04ec7f2e4479d8629.tar.gz
gnu: rust-ghash-0.3: Update to 0.3.1.
* gnu/packages/crates-io.scm (rust-ghash-0.3): Update to 0.3.1.
[cargo-inputs]: Add rust-opaque-debug-0.3.
[cargo-development-inputs]: Replace rust-hex-literal-0.1 with 0.2.

Change-Id: I9d31f34ab836a103c696c0cbf117358c62f18e5d
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 31e25cc941..386d0c6718 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29557,7 +29557,7 @@ authenticated encryption cipher.")
   (package
     (inherit rust-ghash-0.5)
     (name "rust-ghash")
-    (version "0.3.0")
+    (version "0.3.1")
     (source
      (origin
        (method url-fetch)
@@ -29565,13 +29565,14 @@ authenticated encryption cipher.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "0c957q9sk1q93pqqfvhcmflfm1zvbr14aznfpm25kqd6i437zqnn"))))
+         "0xd362xh17hadc2194dd6kjjq0ak1j4x7kkmfmpq9hw2s564wc4p"))))
     (arguments
      `(#:cargo-inputs
-       (("rust-polyval" ,rust-polyval-0.4)
+       (("rust-opaque-debug" ,rust-opaque-debug-0.3)
+        ("rust-polyval" ,rust-polyval-0.4)
         ("rust-zeroize" ,rust-zeroize-1))
        #:cargo-development-inputs
-       (("rust-hex-literal" ,rust-hex-literal-0.1))))))
+       (("rust-hex-literal" ,rust-hex-literal-0.2))))))
 
 (define-public rust-ghash-0.2
   (package