summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-11-03 15:55:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-04 17:03:24 +0100
commita04800b811a8e735de845f2fc379a1641d85f504 (patch)
tree80ed10281f72daf1d18a762abb7212c08c47e722 /gnu/packages
parente16d152463d04792af086ec4505d8a0a41b8206b (diff)
downloadguix-a04800b811a8e735de845f2fc379a1641d85f504.tar.gz
gnu: Add r-mblm.
* gnu/packages/cran.scm (r-mblm): New variable.

Change-Id: Iddfa9bc03a4e5782623253cb70d1ae888545e2ec
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1a5189cbca..76aa645dbf 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3223,6 +3223,27 @@ user-friendly output, and compatibility with tests implemented in R.")
 objects.")
     (license license:gpl3)))
 
+(define-public r-mblm
+  (package
+    (name "r-mblm")
+    (version "0.12.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "mblm" version))
+       (sha256
+        (base32 "1fipb3bryaimr30lcxsxrn0ymv24z39swca7s4z7p9xcfg3ban1b"))))
+    (properties `((upstream-name . "mblm")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/web/packages/mblm/index.html")
+    (synopsis "Median-based linear models")
+    (description
+     "This package provides linear models based on Theil-Sen single median and
+Siegel repeated medians.  They are very robust (29 or 50 percent breakdown
+point, respectively), and if no outliers are present, the estimators are very
+similar to OLS.")
+    (license license:gpl2+)))
+
 (define-public r-mboost
   (package
    (name "r-mboost")