summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:01 +0200
commita0625f70f5a2fed7651aefaf3bed81d8d79f395f (patch)
treea583cb2d2971bd3767c6ec8b0dc614e2697f1649 /gnu/packages
parent4fad3eb0165497c541cca64075e39a5bb694bc61 (diff)
downloadguix-a0625f70f5a2fed7651aefaf3bed81d8d79f395f.tar.gz
gnu: pd: Use G-expressions.
* gnu/packages/music.scm (pd)[arguments]: Rewrite as G-expressions,
and use SEARCH-INPUT-FILE.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 43290bb0ae..aaa8657d27 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2707,19 +2707,21 @@ export.")
     (arguments
      (let ((wish (string-append "wish" (version-major+minor
                                         (package-version tk)))))
-       `(#:tests? #f                    ; no "check" target
-         #:configure-flags
-         (list
-          "--enable-jack"
-          (string-append "--with-wish=" (string-append
-                                         (assoc-ref %build-inputs "tk")
-                                         "/bin/" ,wish)))
-         #:phases
-         (modify-phases %standard-phases
-           (add-before 'configure 'fix-with-path
-             (lambda _
-               (substitute* "tcl/pd-gui.tcl"
-                 (("exec wish ") (string-append "exec " (which ,wish) " ")))))))))
+       (list
+        #:tests? #f                     ; no "check" target
+        #:configure-flags
+        #~(list
+           "--enable-jack"
+           (string-append "--with-wish="
+                          (search-input-file %build-inputs
+                                             (string-append "/bin/" #$wish))))
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-before 'configure 'fix-wish-path
+              (lambda _
+                (substitute* "tcl/pd-gui.tcl"
+                  (("exec wish ")
+                   (string-append "exec " (which #$wish) " ")))))))))
     (native-inputs
      (list autoconf automake libtool gettext-minimal pkg-config))
     (inputs