summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2022-08-06 18:18:53 -0300
committerVinicius Monego <monego@posteo.net>2022-11-05 10:13:50 -0300
commita3eebc7731701c1453f2c33b723e9488354aed0b (patch)
tree910c7835ee89adf9845c5cbbb22b97e64fac702a /gnu/packages
parent2211f50ec1ebcf5f880454b4133ac40e41abac21 (diff)
downloadguix-a3eebc7731701c1453f2c33b723e9488354aed0b.tar.gz
gnu: python-hy: Update to 0.24.0.
* gnu/packages/python-xyz.scm (python-hy): Update to 0.24.0.
[arguments]: Skip more tests and remove old tests in the custom 'check'
phase.
[native-inputs]: Add python-wheel. Replace python-pytest with
python-pytest-7.1.
[propagated-inputs]: Remove python-astor, python-rply.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 635a82eaf5..37807cbcdb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14658,7 +14658,7 @@ with a new public API, and RPython support.")
 (define-public python-hy
   (package
     (name "python-hy")
-    (version "0.20.0")
+    (version "0.24.0")
     (source
      (origin
        (method git-fetch)               ; no tests in PyPI release
@@ -14667,7 +14667,7 @@ with a new public API, and RPython support.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1g7djra9z7b0wyqyfrk2n4z3zamp2xkahv00jwdv35xmwwn09hq4"))))
+        (base32 "1s458ymd9g3s8k2ccc300jr4w66c7q3vhmhs9z3d3a4qg0xdhs9y"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -14677,13 +14677,14 @@ with a new public API, and RPython support.")
              (when tests?
                (invoke "python" "-m" "pytest" "-k"
                        (string-append   ; skip some failed tests
-                        "not test_bin_hy_sys_executable"
-                        " and not test_bin_hy_circular_macro_require"
-                        " and not test_macro_from_module"))))))))
+                        "not test_sys_executable"
+                        " and not test_circular_macro_require"
+                        " and not test_macro_require"
+                        " and not test_requires_pollutes_core"))))))))
     (native-inputs
-     (list python-pytest))
+     (list python-pytest-7.1 python-wheel))
     (propagated-inputs
-     (list python-astor python-colorama python-funcparserlib python-rply))
+     (list python-colorama python-funcparserlib))
     (home-page "https://docs.hylang.org/en/stable/")
     (synopsis "Lisp frontend to Python")
     (description