summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-09-06 02:46:49 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-09-07 09:07:53 +0200
commita5e177117b0313940763334826978975e9ba2798 (patch)
tree3299e2cf5bf4b7b4bf77336e6ed0a33d2507ffb8 /gnu/packages
parentf3c9c2fbc3a6cbb1a476742e37766dbea8da78af (diff)
downloadguix-a5e177117b0313940763334826978975e9ba2798.tar.gz
gnu: Add python-flake8-pie.
* gnu/packages/python-xyz.scm (python-flake8-pie): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 078779be06..3e149a3ef5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8181,6 +8181,24 @@ expressions after the entire file has been read.  This enables support for
 first-class forward references that stub files use.")
     (license license:expat)))
 
+(define-public python-flake8-pie
+  (package
+    (name "python-flake8-pie")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "flake8-pie" version))
+       (sha256
+        (base32 "0kgipl5gljlp7aa7ykx15pswpzkd0d0qiznihb2z0d9a73181dyd"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/sbdchd/flake8-pie")
+    (synopsis "Flake8 extension that implements lints")
+    (description
+     "This package provides a flake8 extension that implements miscellaneous
+lints.")
+    (license license:bsd-2)))
+
 (define-public python-mistune
   (package
     (name "python-mistune")