summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commita78c0059aa68180ecac6cc99487081540aaac192 (patch)
tree8473928f7de6c7532c75e0b2e690023a1717e252 /gnu/packages
parentfb64e563eb8ee7fcfe67451cf73d1ec1917bf9d6 (diff)
downloadguix-a78c0059aa68180ecac6cc99487081540aaac192.tar.gz
gnu: Add ghc-mattermost-api-qc.
* gnu/packages/haskell-web.scm (ghc-mattermost-api-qc): New variable.

Change-Id: If28b8a03170bb235b2418329d408fec8f06d4b7c
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index fc101fba05..cea4d09544 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -884,6 +884,27 @@ Mattermost is a flexible messaging platform.  This library provides network
 API interaction with the Mattermost server.")
     (license license:bsd-3)))
 
+(define-public ghc-mattermost-api-qc
+  (package
+    (name "ghc-mattermost-api-qc")
+    (version "90000.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (hackage-uri "mattermost-api-qc" version))
+       (sha256
+        (base32 "0lrb8l8nbrdp4y2ala8hchr8ikv5hqw710ffiiw1sz6z2dqiqbxm"))))
+    (build-system haskell-build-system)
+    (properties '((upstream-name . "mattermost-api-qc")))
+    (inputs (list ghc-mattermost-api ghc-quickcheck))
+    (home-page "https://github.com/matterhorn-chat/mattermost-api-qc")
+    (synopsis "QuickCheck instances for the Mattermost client API library")
+    (description
+     "This package provides a library providing @code{QuickCheck} for the
+mattermost-api library to allow testing.  This is provided as a separate
+library to allow use of the API library without testing dependencies.")
+    (license license:isc)))
+
 (define-public ghc-mime-types
   (package
     (name "ghc-mime-types")