summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-04 02:50:46 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-07-04 02:52:26 +0200
commita8a964db83dd49d8bb58574eccd9bfd7aebfba4b (patch)
treee8af48e940d347da5b5699ca4e8698ebd4bde5e2 /gnu/packages
parentde2f56cf96c70d5d3e61809621e71864f5a7f51e (diff)
downloadguix-a8a964db83dd49d8bb58574eccd9bfd7aebfba4b.tar.gz
gnu: python-pylint: Update to 1.7.2.
* gnu/packages/python.scm (python-pylint): Update to 1.7.2.
[native-inputs]: Add PYTHON-PYTEST and PYTHON-PYTEST-RUNNER.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 54ab56eeae..546ac8d7b3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14023,7 +14023,7 @@ statements in the module it tests.")
 (define-public python-pylint
   (package
     (name "python-pylint")
-    (version "1.6.5")
+    (version "1.7.2")
     (source
      (origin
        (method url-fetch)
@@ -14032,10 +14032,12 @@ statements in the module it tests.")
              version ".tar.gz"))
        (sha256
         (base32
-         "08pmgflmq2zrzrn9nkfadzwa5vybz46wvwxhrsd2mjlcgsh4rzbm"))))
+         "0mzn1czhf1mgr2wiqfihb274sja02h899b85kywdpivppa9nwrmp"))))
     (build-system python-build-system)
     (native-inputs
-     `(("python-tox" ,python-tox)))
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-runner" ,python-pytest-runner)
+       ("python-tox" ,python-tox)))
     (propagated-inputs
      `(("python-astroid" ,python-astroid)
        ("python-isort" ,python-isort)