summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:43 +0200
commitab7284fbcdf7d997a7d5dd5538b16792217380fd (patch)
tree586b2b25739c2c866b1f07cc0d709ea598f66579 /gnu/packages
parentf8958cf5c8c5cb367b599d4253e4f0d71e5aab09 (diff)
downloadguix-ab7284fbcdf7d997a7d5dd5538b16792217380fd.tar.gz
gnu: Add texlive-tamefloats.
* gnu/packages/tex.scm (texlive-tamefloats): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index eeb9347e94..2e0ac97423 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -97419,6 +97419,29 @@ whatsoever.  The entire look and feel of the presentation can be defined by
 the user.")
     (license license:lppl)))
 
+(define-public texlive-tamefloats
+  (package
+    (name "texlive-tamefloats")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/tamefloats/"
+                   "tex/latex/tamefloats/")
+             (base32
+              "1qsmyw732ilgdwhwhh4dnd1yhk2x3hn95sn9v6aq58mdlhax2cv0")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tamefloats")
+    (synopsis "Experimentally use @code{\\holdinginserts} with LaTeX floats")
+    (description
+     "LaTeX's figures, tables, and @code{\\marginpars} are dangerous for footnotes (and
+probably also @code{\\enlargethispage}).  Here is a proposal (a patch package) to help,
+by using @code{\\holdinginserts} in a simple way.  It replaces the original problem with
+a new one --- it is an experiment to find out whether the new problem is less bad
+(or it is just a contribution to the discussion, maybe just a summary of
+previous work).")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar