summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-01-27 19:56:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-01-27 19:56:56 +0100
commitaccfabf6d5870a50f27b04132b63783eb07a9677 (patch)
treec6fe87c1e8fd19ea3426d1de5c14b604944703a3 /gnu/packages
parent5e9b141675e46da042b5268f405afa5b272d6415 (diff)
downloadguix-accfabf6d5870a50f27b04132b63783eb07a9677.tar.gz
gnu: python-networkx: Update to 2.1.
* gnu/packages/python.scm (python-networkx): Update to 2.1.
[source](uri): Change to zipball.
[native-inputs]: Add UNZIP.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 439c05b665..6b4167b36c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4861,19 +4861,20 @@ interfaces in an easy and portable manner.")
 (define-public python-networkx
   (package
     (name "python-networkx")
-    (version "1.11")
+    (version "2.1")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "networkx" version))
+       (uri (pypi-uri "networkx" version ".zip"))
        (sha256
-        (base32 "1f74s56xb4ggixiq0vxyfxsfk8p20c7a099lpcf60izv1php03hd"))))
+        (base32 "1ccb8mfz4m821k9y0cigkbq42q2sbb4dj5fbjshp0awp32j2q9v4"))))
     (build-system python-build-system)
     ;; python-decorator is needed at runtime
     (propagated-inputs
      `(("python-decorator" ,python-decorator)))
     (native-inputs
-     `(("python-nose" ,python-nose)))
+     `(("python-nose" ,python-nose)
+       ("unzip" ,unzip)))
     (home-page "http://networkx.github.io/")
     (synopsis "Python module for creating and manipulating graphs and networks")
     (description