summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 12:07:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:23 +0200
commitb05996d2eae9f0ce0e1982c9d6f50adc7c13646e (patch)
tree7bf3fef6341fca0d50846815f0f875e82b9f7dfc /gnu/packages
parenta418ba4039a9af76c00986759b8740542607ef00 (diff)
downloadguix-b05996d2eae9f0ce0e1982c9d6f50adc7c13646e.tar.gz
gnu: Add rust-pbr-1.
* gnu/packages/crates-graphics.scm (rust-pbr-1): New variable.

Change-Id: I82ebaa90c7f76bd02c760257b022a88e44413146
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-graphics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index d3e5d16f56..c963b3d6f7 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2351,6 +2351,30 @@ on correctness, flexibility and ease of use.")
 @code{palette} crate.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-pbr-1
+  (package
+    (name "rust-pbr")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pbr" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "056mqvw168ziig1dgl2kq4vmkamv6gk3hv1x9696r6ynl3gjfn7d"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-test-flags '("--release" "--"
+                            "--skip=tty::unix::compare_with_stty")
+       #:cargo-inputs (("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
+                       ("rust-libc" ,rust-libc-0.2)
+                       ("rust-winapi" ,rust-winapi-0.3))
+       #:cargo-development-inputs (("rust-rand" ,rust-rand-0.8))))
+    (home-page "https://github.com/a8m/pb")
+    (synopsis "Console progress bar for Rust")
+    (description "This package provides a console progress bar for Rust.")
+    (license license:expat)))
+
 (define-public rust-piston-float-1
   (package
     (name "rust-piston-float")