summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-03 21:52:07 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-03-03 21:52:07 +0200
commitb13747e977be1c872299d6757c088ebe87a52dd0 (patch)
tree78b1f6b90685b2fc83cba43f9b259f95fa83a0ff /gnu/packages
parentf00f56514d90ebba5d9e08ec786c8118e437097c (diff)
downloadguix-b13747e977be1c872299d6757c088ebe87a52dd0.tar.gz
gnu: vim: Update to 9.1.0146.
* gnu/packages/vim.scm (vim): Update to 9.1.0146.
[arguments]: Adjust 'patch-absolute-paths phase to patch another /bin/sh
invocation.

Change-Id: I61e65988b96561bd10c9d35506e24c702cfb38d3
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/vim.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 7cacdd5f06..6b5eaabf8e 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -86,7 +86,7 @@
 (define-public vim
   (package
     (name "vim")
-    (version "9.1.0059")
+    (version "9.1.0146")
     (source (origin
              (method git-fetch)
              (uri (git-reference
@@ -95,7 +95,7 @@
              (file-name (git-file-name name version))
              (sha256
               (base32
-               "146zhwhagdsbsh3h7f8h7izbzrwh3hgry4cx2lalq9s275qy3hzb"))))
+               "05lz8ai39p9ypk22n7qc7g21868m08pl12sn4028jshx5nxwy2zn"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
@@ -116,7 +116,8 @@
                (("/bin/sh") (which "sh")))
              (substitute* "src/testdir/test_autocmd.vim"
                (("/bin/kill") (which "kill")))
-             (substitute* "src/if_cscope.c"
+             (substitute* '("runtime/syntax/sh.vim"
+                            "src/if_cscope.c")
                (("/bin/sh") (search-input-file inputs "/bin/sh")))))
          (add-before 'check 'set-environment-variables
            (lambda* (#:key inputs #:allow-other-keys)