summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-04 18:29:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-04 19:53:31 +0100
commitb19c12c2d7d274bcebc5195e22ccf7721391519e (patch)
tree3846b9c0770b06428220cd55404b784437724322 /gnu/packages
parent04f8295f6f91d8a5c75a212fc4b0a5174d89b996 (diff)
downloadguix-b19c12c2d7d274bcebc5195e22ccf7721391519e.tar.gz
gnu: Add python-pyts.
* gnu/packages/python-science.scm (python-pyts): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-science.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 94a4c922a5..b389a27a9a 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -501,6 +501,47 @@ annotated with a few interface descriptions and turns it into a native
 Python module with the same interface, but (hopefully) faster.")
     (license license:bsd-3)))
 
+(define-public python-pyts
+  (package
+    (name "python-pyts")
+    (version "0.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pyts" version))
+              (sha256
+               (base32
+                "1cb5jwp8g52a3hxay6mxbfzk16ly6yj6rphq8cwbwk1k2jdf11dg"))))
+    (build-system python-build-system)
+    (arguments
+     (list
+      #:phases
+      '(modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "pytest" "-v"
+                       ;; XXX: This test fails for unknown reasons
+                       ;; Expected:
+                       ;;  (40, 9086)
+                       ;; Got:
+                       ;; (40, 9088)
+                       "-k"
+                       "not pyts.multivariate.transformation.weasel_muse.WEASELMUSE")))))))
+    (propagated-inputs
+     (list python-joblib
+           python-matplotlib
+           python-numba
+           python-numpy
+           python-scikit-learn
+           python-scipy))
+    (native-inputs
+     (list python-pytest python-pytest-cov))
+    (home-page "https://github.com/johannfaouzi/pyts")
+    (synopsis "Python package for time series classification")
+    (description
+     "This package provides a Python package for time series classification.")
+    (license license:bsd-3)))
+
 (define-public python-bottleneck
   (package
     (name "python-bottleneck")