summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:13:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:45 +0200
commitb1b153569b01ed95c4cabad0503d140a4252acf0 (patch)
treeea78e43e558128a6d73735a252ab8d19573211c4 /gnu/packages
parentacdb19ce219b9612f8d5304184d096954b74c3d4 (diff)
downloadguix-b1b153569b01ed95c4cabad0503d140a4252acf0.tar.gz
gnu: Add texlive-llncs.
* gnu/packages/tex.scm (texlive-llncs): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e92b7dee11..db4700a6ef 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19646,6 +19646,29 @@ texts, particularly @code{Missal} and @code{Breviary} texts.  The package
 assumes availability of Latin typesetting packages.")
     (license license:lppl)))
 
+(define-public texlive-llncs
+  (package
+    (name "texlive-llncs")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/llncs/" "doc/latex/llncs/"
+                   "tex/latex/llncs/")
+             (base32
+              "0drz45rmjprwy2019nkd6l5kjpqshfajqhg0x6jf5y9w1zbs1qv5")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/llncs")
+    (synopsis
+     "Document class and bibliography style for @acronym{LNCS, Lecture Notes
+in Computer Science}")
+    (description
+     "This is Springer's official macro package for typesetting contributions
+to be published in Springer's @acronym{LNCS, Lecture Notes in Computer
+Science} and its related proceedings series CCIS, LNBIP, LNICST, and IFIP
+AICT.")
+    (license license:cc-by4.0)))
+
 (define-public texlive-lobster2
   (package
     (name "texlive-lobster2")