summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-12-14 11:55:04 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-12-21 19:22:53 +0200
commitb4e9e72ecf722fe7397b49e729f2346824769c04 (patch)
tree602c36943eb89bbad746fecda100b73b92b9f04d /gnu/packages
parent3fe107790287f6e8fe2c8b570152e89c32532c6c (diff)
downloadguix-b4e9e72ecf722fe7397b49e729f2346824769c04.tar.gz
gnu: julia-requires: Update to 1.3.0.
* gnu/packages/julia-xyz.scm (julia-requires): Update to 1.3.0.
[propagated-inputs, inputs]: Move packages ...
[native-inputs]: ... to here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 0f060aecdd..9dfb7b0cd6 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4869,7 +4869,7 @@ package can help create and update if need be.")
 (define-public julia-requires
   (package
     (name "julia-requires")
-    (version "1.1.3")
+    (version "1.3.0")
     (source
      (origin
        (method git-fetch)
@@ -4878,14 +4878,13 @@ package can help create and update if need be.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "03hyfy7c0ma45b0y756j76awi3az2ii4bz4s8cxm3xw9yy1z7b01"))))
+        (base32 "0gmqs7f17aq500lbdff4ibws00f8m0pnzskvf4b3ig520xv3n3nm"))))
     (build-system julia-build-system)
     (arguments
-     (list #:parallel-tests? #f))
-    (inputs                             ;required for test
-     (list julia-example))
-    (propagated-inputs
-     (list julia-colors))
+     (list #:parallel-tests? #f))       ; Test suite has race conditions.
+    (native-inputs
+     (list julia-colors
+           julia-example))
     (home-page "https://github.com/JuliaPackaging/Requires.jl/")
     (synopsis "Faster package loader")
     (description "This package make loading packages faster, maybe.  It