summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-25 16:15:50 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2023-07-13 19:00:09 +0200
commitb4fe82bd8af735000d0f2165a23cfb695c181f6f (patch)
tree85f7457dbedf4200d0f31d8e03178e9cac02cba2 /gnu/packages
parent9c1957921a1f53973c9b4b895f6d6d5fa63fe2dd (diff)
downloadguix-b4fe82bd8af735000d0f2165a23cfb695c181f6f.tar.gz
gnu: gnumach: Disable builtin networking.
See also

    https://logs.guix.gnu.org/hurd/2023-05-25.log#163610

* gnu/packages/hurd.scm (gnumach)[arguments]: Add --disable-net-group,
--disable-pcmcia-group, and --disable-wireless-group.

Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/hurd.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 5072b7de2b..7e788d398d 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -264,7 +264,11 @@ Hurd-minimal package which are needed for both glibc and GCC.")
        ((#:make-flags flags ''())
         `(cons "CFLAGS=-fcommon" ,flags))
        ((#:configure-flags flags ''())
-        `(cons "--enable-kdb" ,flags))            ;enable kernel debugger
+        `(cons* "--enable-kdb" ;enable kernel debugger
+                "--disable-net-group"
+                "--disable-pcmcia-group"
+                "--disable-wireless-group"
+               ,flags))
        ((#:phases phases '%standard-phases)
         `(modify-phases %standard-phases
            (add-after 'install 'produce-image