summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Pflug <david@pflug.io>2024-02-11 09:16:38 +0100
committerAndreas Enge <andreas@enge.fr>2024-02-11 09:20:16 +0100
commitb6439fc5f800b5d22d48192bc347be794f050329 (patch)
treed505cddadee6b98fc25a2b8c0686e7a0b7d2724c /gnu/packages
parent9edbb2d7a40c9da7583a1046e39b87633459f656 (diff)
downloadguix-b6439fc5f800b5d22d48192bc347be794f050329.tar.gz
gnu: Add python-gguf.
* gnu/packages/machine-learning.scm (python-gguf): New variable.

Change-Id: Icf6138486cccc5b4c3141424baccf17c4edb3449
Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/machine-learning.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 7653608fd9..2e20872555 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -24,6 +24,7 @@
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
 ;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 David Pflug <david@pflug.io>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5365,3 +5366,23 @@ Brian 2 simulator.")
      "OneAPI Deep Neural Network Library (oneDNN) is a cross-platform
 performance library of basic building blocks for deep learning applications.")
     (license license:asl2.0)))
+
+(define-public python-gguf
+  (package
+    (name "python-gguf")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "gguf" version))
+       (sha256
+        (base32 "0rbyc2h3kpqnrvbyjvv8a69l577jv55a31l12jnw21m1lamjxqmj"))))
+    (build-system pyproject-build-system)
+    (arguments
+      (list #:tests? #false))
+    (inputs (list poetry python-pytest))
+    (propagated-inputs (list python-numpy))
+    (home-page "https://ggml.ai")
+    (synopsis "Read and write ML models in GGUF for GGML")
+    (description "A Python library for reading and writing GGUF & GGML format ML models.")
+    (license license:expat)))