summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:27:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:17 +0200
commitb761d118c2b2bd5de396d952d8ce6802e9072c82 (patch)
tree8eb716e4a643ab4ca8fdb10adcffc88a62eeca6f /gnu/packages
parenteb1d71a427b3c5cd59bba9f8877f7ee9c2b95d82 (diff)
downloadguix-b761d118c2b2bd5de396d952d8ce6802e9072c82.tar.gz
gnu: Add texlive-ipaex-type1.
* gnu/packages/tex.scm (texlive-ipaex-type1): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5083bda59d..c634453bbe 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -15099,6 +15099,29 @@ journals, including @emph{Journal of Physics}.")
 proportional width glyphs for Western characters.")
     (license license:ipa)))
 
+(define-public texlive-ipaex-type1
+  (package
+    (name "texlive-ipaex-type1")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/ipaex-type1/"
+                   "fonts/enc/dvips/ipaex-type1/"
+                   "fonts/map/dvips/ipaex-type1/"
+                   "fonts/tfm/public/ipaex-type1/"
+                   "fonts/type1/public/ipaex-type1/"
+                   "tex/latex/ipaex-type1/")
+             (base32
+              "123m8i8gvyq3cncn8s11qzk976ml89aqcyapx2zs6phg9h090bc8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/ipaex-type1")
+    (synopsis "IPAex fonts converted to Type-1 format Unicode sub-fonts")
+    (description
+     "The package contains the IPAex Fonts converted into Unicode sub-fonts in
+Type 1 format, which is most suitable for use with the CJK package.")
+    (license license:ipa)))
+
 (define-public texlive-is-bst
   (package
     (name "texlive-is-bst")