summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-01 22:04:16 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-04-06 01:58:20 +0200
commitb89201695582351fa5fa183c7a1aa26162ca271e (patch)
tree07cf713d02ab30768c5800189955d0505b7d3452 /gnu/packages
parent62e9f00ce2391b062afa3ed96dfd34a3d0762af7 (diff)
downloadguix-b89201695582351fa5fa183c7a1aa26162ca271e.tar.gz
gnu: Add msamr.
* gnu/packages/linphone (msamr): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linphone.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 68a4e3e140..5023c5f645 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -532,3 +532,33 @@ AMR codec.  It is based on the Skype's SILK implementation.")
 WebRTC codec.  It includes features from WebRTC, such as, iSAC and AECM.")
     (home-page "https://gitlab.linphone.org/BC/public/mswebrtc")
     (license license:gpl2+)))
+
+(define-public msamr
+  (package
+    (name "msamr")
+    (version "1.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://www.linphone.org/releases/sources/plugins/"
+                       name "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32 "16c9f3z4wnj73k7y8gb0fgpr4axsm7b5zrbjvy8vsgz9gyg3agm5"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f                      ; No test target
+       #:configure-flags
+       (list
+        "-DENABLE_STATIC=NO"            ; Not required
+        "-DENABLE_WIDEBAND=YES")))
+    (inputs
+     `(("mediastreamer2" ,mediastreamer2)
+       ("opencoreamr" ,opencore-amr)
+       ("ortp" ,ortp)
+       ("voamrwbenc" ,vo-amrwbenc)))
+    (synopsis "Media Streamer AMR Codec")
+    (description "MSAMR is a plugin of MediaStreamer, adding support for
+AMR codec.  It is based on the opencore-amr implementation.")
+    (home-page "https://gitlab.linphone.org/BC/public/msamr")
+    (license license:gpl3+)))