summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:28 +0200
commitbdb97d1758ab973b21f8bee595c1e1096ad24546 (patch)
treec0cdbb3f0b7d02e805e5d09da7c120e984a7fa15 /gnu/packages
parenta976e821d2d80f1393f9c05adfa1fd6151f2c24a (diff)
downloadguix-bdb97d1758ab973b21f8bee595c1e1096ad24546.tar.gz
gnu: Add texlive-wordcount.
* gnu/packages/tex.scm (texlive-wordcount): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e4b42937ce..58121fe670 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99809,6 +99809,29 @@ substitution.  It also allows you to carefully control argument expansion
 using a LaTeX3-style argument specification.")
     (license license:lppl1.3+)))
 
+(define-public texlive-wordcount
+  (package
+    (name "texlive-wordcount")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/wordcount/" "scripts/wordcount/"
+                   "tex/latex/wordcount/")
+             (base32
+              "1x4qx3skvlndinligp0k2j8dpgpkim6374vc4fxfjrsd2bhw2fnm")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "wordcount.sh")))
+    (home-page "https://ctan.org/pkg/wordcount")
+    (synopsis "Estimate the number of words in a LaTeX document")
+    (description
+     "The package provides a relatively easy way of estimating the number of words
+in a LaTeX document.  It requires something like Unix @samp{grep -c} that can
+search a file for a particular string and report the number of matching lines.
+An accompanying shell script @file{wordcount.sh} contains more information in
+its comments.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar