summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAdriano Peluso <catonano@gmail.com>2018-01-22 18:58:45 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2018-01-22 19:52:22 +0100
commitbf3563d5a4cbd8ff83b564442105d1f0d5e100e2 (patch)
tree3362fb9bcf0a2213d2fe35104f3796a799d3fd84 /gnu/packages
parent09b9cf7327f1cdaee31e9a176451a263d56cec5b (diff)
downloadguix-bf3563d5a4cbd8ff83b564442105d1f0d5e100e2.tar.gz
gnu: Add python-proteus.
* gnu/packages/tryton.scm (python-proteus): New variable.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tryton.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 1fa6d4e5ba..b4fb008772 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -92,3 +92,24 @@ and security.")
     (synopsis "Client component of Tryton")
     (description "This package is the client component of Tryton.")
     (license license:gpl3+)))
+
+(define-public python-proteus
+  (package
+    (name "python-proteus")
+    (version "4.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "proteus" version))
+       (sha256
+        (base32
+         "0flkf1vxbhz51b7bq31dn7q9mlkli3pmpbzfhsxfqpf6laghbkqg"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-dateutil" ,python-dateutil)))
+    (home-page "http://www.tryton.org/")
+    (synopsis
+     "Library to access a Tryton server as a client")
+    (description
+     "This package provides a library to access Tryton server as a client.")
+    (license license:lgpl3+)))