summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2022-09-05 09:53:19 +0200
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2022-09-05 09:53:19 +0200
commitc01b5a2abb4c0970a2d74f4716992458b462b483 (patch)
treeae67bec555e5790f100f6947856443edec5c933a /gnu/packages
parent31b4eea5c0d361dfbca119c27cbc1e8c6f65782a (diff)
downloadguix-c01b5a2abb4c0970a2d74f4716992458b462b483.tar.gz
gnu: Add r-reghelper.
* gnu/packages/statistics.scm (r-reghelper): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/statistics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 60ec8bc3a3..dd5636edac 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -7129,3 +7129,25 @@ otting the results.")
        "This package provides a collection of (mostly simple) functions for
 generating and manipulating colors in R.")
       (license license:gpl3))))
+
+(define-public r-reghelper
+  (package
+    (name "r-reghelper")
+    (version "1.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "reghelper" version))
+              (sha256
+               (base32
+                "0v1987rs6kcpizfhrp3hxsyx9arn5vsbapjfgj9478j73mm844ji"))))
+    (properties `((upstream-name . "reghelper")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-ggplot2 r-lme4 r-mass r-nlme))
+    (home-page "https://github.com/jeff-hughes/reghelper")
+    (synopsis "Helper Functions for Regression Analysis")
+    (description
+     "This package provides a set of functions used to automate commonly used methods
+in regression analysis.  This includes plotting interactions, and calculating
+simple slopes, standardized coefficients, regions of significance (Johnson &
+Neyman, 1936; cf.  Spiller et al., 2012), etc.")
+    (license license:gpl3)))