summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:45:52 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:31 +0200
commitc058f86b1c2e44e0b8f54ac72f7c7b4335bade6d (patch)
tree72a843ae55652e2082be677a333588a7f1ef546b /gnu/packages
parent9526fa75fcb96aa42682ac05eec6ee7fe59643e7 (diff)
downloadguix-c058f86b1c2e44e0b8f54ac72f7c7b4335bade6d.tar.gz
gnu: Add texlive-nkarta.
* gnu/packages/tex.scm (texlive-nkarta): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f6896881c7..b3d05c0418 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19692,6 +19692,29 @@ the size and colour of the sticks, and flexibility to draw heaps of different
 objects.")
     (license license:expat)))
 
+(define-public texlive-nkarta
+  (package
+    (name "texlive-nkarta")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/nkarta/"
+                   "fonts/source/public/nkarta/"
+                   "fonts/tfm/public/nkarta/"
+                   "metapost/nkarta/" "source/latex/nkarta/")
+             (base32
+              "0x5rdacf3d2jm4rgcvmpz76icga4gis4ykmsmp745xb7kh99npjv")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (native-inputs (list texlive-metafont))
+    (home-page "https://ctan.org/pkg/nkarta")
+    (synopsis "New version of the Karta cartographic fonts")
+    (description
+     "This package provides a development of the Karta font, offering more
+mathematical stability in Metafont.  A version that will produce the glyphs as
+Encapsulated PostScript is also provided.")
+    (license license:public-domain)))
+
 (define-public texlive-nmbib
   (package
     (name "texlive-nmbib")