summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-02-29 00:19:01 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-03-03 17:22:18 +0100
commitc06c7a3aec38471dae3fb88f64558921003b2590 (patch)
treedbe3b8ff38c926d56e4b245f22e257a21f4450ed /gnu/packages
parent7dffb5bacea543e983de16b6d746159602acd6d3 (diff)
downloadguix-c06c7a3aec38471dae3fb88f64558921003b2590.tar.gz
gnu: linux: Add lsscsi.
* gnu/packages/linux.scm (lsscsi): New variable.

Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5f2d37deda..64ea566dbd 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -41,6 +41,7 @@
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1842,6 +1843,27 @@ IPv6 packet filter.
 Both commands are targeted at system administrators.")
     (license license:gpl2+)))
 
+(define-public lsscsi
+  (package
+    (name "lsscsi")
+    (version "0.31")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "http://sg.danny.cz/scsi/lsscsi-" version ".tar.xz"))
+             (sha256
+              (base32
+               "1ry2y34xmpgxdbfbyvs8cjmbx0fn222yjdab87wj21q60nab5p75"))))
+    (build-system gnu-build-system)
+    (synopsis "Lists information about SCSI or NVMe devices in Linux")
+    (home-page "http://sg.danny.cz/scsi/lsscsi.html")
+    (description
+     "@command{lsscsi} lists SCSI logical units or SCSI targets.  It can
+also list NVMe namespaces or controllers and show the relationship between a
+device's primary node name, its SCSI generic (sg) node name and its kernel
+name.")
+    (license license:gpl2)))
+
 (define-public ebtables
   (package
     (name "ebtables")