summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-09-06 18:51:09 +0800
committerLudovic Courtès <ludo@gnu.org>2023-09-14 22:58:59 +0200
commitc0bfa12666cc6dc706981c76b9ee5c7f9006932d (patch)
tree034a947ba8e01006addb03e072fe36d15082f7ff /gnu/packages
parentca5fae4f26f2f35412a96fe2042883341ca62182 (diff)
downloadguix-c0bfa12666cc6dc706981c76b9ee5c7f9006932d.tar.gz
gnu: uncrustify: use new style and gexp.
* gnu/packages/code.scm (uncrustify): use new style and gexp.
[native-inputs]: remove label.
[arguments]: use gexp and remove tail #t.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/code.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index a9e94dab25..b716f32599 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -805,20 +805,18 @@ independent targets.")
                (base32
                 "17x9p5pqgzjchi9xhskp4kq7ag4chmsgbkvwym5m2b9zwm6qykpm"))))
     (build-system cmake-build-system)
-    (native-inputs
-     `(("python" ,python-wrapper)))
+    (native-inputs (list python-wrapper))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'unpack-etc
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             ;; Configuration samples are not installed by default.
-             (let* ((output (assoc-ref outputs "out"))
-                    (etcdir (string-append output "/etc")))
-               (for-each (lambda (l)
-                           (install-file l etcdir))
-                         (find-files "etc" "\\.cfg$")))
-             #t)))))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'unpack-etc
+                 (lambda* (#:key inputs outputs #:allow-other-keys)
+                   ;; Configuration samples are not installed by default.
+                   (let* ((output (assoc-ref outputs "out"))
+                          (etcdir (string-append output "/etc")))
+                     (for-each (lambda (l)
+                                 (install-file l etcdir))
+                               (find-files "etc" "\\.cfg$"))))))))
     (home-page "https://uncrustify.sourceforge.net/")
     (synopsis "Code formatter for C and other related languages")
     (description