summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:38 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:22 +0300
commitc0dfd0470945b1e2d560aa2efc348283b8be0d39 (patch)
treec6bd538cbbeabcb269cef16a379a93322316c9a2 /gnu/packages
parent308bee5f000703f063f5fbccd1c439e8c905a09c (diff)
downloadguix-c0dfd0470945b1e2d560aa2efc348283b8be0d39.tar.gz
gnu: Add python-synphot.
* gnu/packages/astronomy.scm (python-synphot): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c411af0e54..d82ff7c91f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2832,6 +2832,33 @@ Takes a WGS84 (GPS) latitude/longitude as input as well as an UTC or local
 datetime object.")
     (license license:lgpl3+)))
 
+(define-public python-synphot
+  (package
+    (name "python-synphot")
+    (version "1.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "synphot" version))
+              (sha256
+               (base32
+                "02pjp1bnbyq7zi1bxqv56nif4ijd8fscmnn9ldrs8yvgsbmgdvlc"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      ;; XXX: Test needs more love to pass.
+      ;; ERROR collecting synphot/tests/test_utils.py
+      #:tests? #f))
+    (propagated-inputs (list python-astropy python-numpy python-scipy))
+    (native-inputs (list python-pytest python-pytest-astropy
+                         python-setuptools-scm))
+    (home-page "https://github.com/spacetelescope/synphot_refactor")
+    (synopsis "Synthetic photometry using Astropy")
+    (description
+     "This package provides a replacement for IRAF STSDAS SYNPHOT and ASTROLIB
+PYSYNPHOT, utilizing Astropy and covering the non-instrument specific portions
+of the old packages.")
+    (license license:bsd-3)))
+
 (define-public python-tweakwcs
   (package
     (name "python-tweakwcs")