summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 11:53:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:32 +0200
commitc2fe35567706c8f2a549638dd461231c296cc290 (patch)
tree2a018bdbaf04e98a67ef3244086d7913d6bed02d /gnu/packages
parenta2c34444c730f1a6c2004523df4b027f230b1099 (diff)
downloadguix-c2fe35567706c8f2a549638dd461231c296cc290.tar.gz
gnu: Add texlive-bibunits.
* gnu/packages/tex.scm (texlive-bibunits): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 40dfd5a7f4..245c34d930 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4916,6 +4916,30 @@ references to entries in bibliographies produced by the @code{bibtopic}
 package.")
     (license license:lppl)))
 
+(define-public texlive-bibunits
+  (package
+    (name "texlive-bibunits")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/bibunits/"
+                   "source/latex/bibunits/"
+                   "tex/latex/bibunits/")
+             (base32
+              "0hlz277lskhcs5xr0qn2rram957himj67hkwqqsjjap8khf7fz6v")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/bibunits")
+    (synopsis "Multiple bibliographies in one document")
+    (description
+     "The package provide a mechanism to generate separate bibliographies for
+different units (chapters, sections or bibunit-environments) of a text.  The
+package separates the citations of each unit of text into a separate file to
+be processed by BibTeX.  The global bibliography section produced by LaTeX may
+also appear in the document and citations can be placed in both the local unit
+and the global bibliographies at the same time.")
+    (license license:lppl)))
+
 (define-public texlive-binomexp
   (package
     (name "texlive-binomexp")