summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:36:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:20 +0200
commitc335c5f661947c84c26532dfe73631c27aaf5b6d (patch)
treebc7efcc1ecd6c34efdfb7ad8309d89393400f218 /gnu/packages
parentb42c197a515f4ab266623306937ea713d5f4d01f (diff)
downloadguix-c335c5f661947c84c26532dfe73631c27aaf5b6d.tar.gz
gnu: Add texlive-collection-fontutils.
* gnu/packages/tex.scm (texlive-collection-fontutils): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0059a0c8eb..6a067a0dc6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -19366,6 +19366,42 @@ PostScript fonts, Latin Modern, TeX Gyre, and T1 and other encoding support
 for Computer Modern, in outline form.")
     (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
 
+(define-public texlive-collection-fontutils
+  (package
+    (name "texlive-collection-fontutils")
+    (version (number->string %texlive-revision))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments (list #:builder #~(mkdir #$output)))
+    (propagated-inputs
+     (list texlive-accfonts
+           texlive-afm2pl
+           texlive-albatross
+           texlive-collection-basic
+           texlive-dosepsbin
+           texlive-dvipsconfig
+           texlive-epstopdf
+           texlive-fontinst
+           texlive-fontools
+           texlive-fontware
+           texlive-lcdftypetools
+           texlive-luafindfont
+           texlive-metatype1
+           texlive-mf2pt1
+           texlive-ps2eps
+           texlive-ps2pk
+           texlive-psutils
+           texlive-t1utils
+           texlive-ttfutils))
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "Graphics and font utilities")
+    (description
+     "This collection of packages provides programs for conversion between
+font formats, testing fonts, virtual fonts, @file{.gf} and @file{.pk}
+manipulation, mft, fontinst, etc.  Manipulating OpenType, TrueType, Type 1,and
+for manipulation of PostScript and other image formats.")
+    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
 (define-public texlive-collection-latex
   (package
     (name "texlive-collection-latex")