summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2022-11-12 20:13:13 -0500
committerDavid Thompson <dthompson2@worcester.edu>2022-11-12 20:13:13 -0500
commitc4025af8c11c3e9ea0c2747b6c475c916fb61d80 (patch)
tree3de976c5e2000e8a02cf8a3634ad926555f6353e /gnu/packages
parent42d1fa6fc4faabe9a4c327014c7289dda08ad8a2 (diff)
downloadguix-c4025af8c11c3e9ea0c2747b6c475c916fb61d80.tar.gz
gnu: guile-websocket: Update to 0.1.
* gnu/packages/guile-xyz.scm (guile-websocket): Update to 0.1.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/guile-xyz.scm49
1 files changed, 22 insertions, 27 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index a01fabc474..5997a24577 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4225,34 +4225,29 @@ Relay Chat} (IRC).")
       (license license:lgpl2.1+))))
 
 (define-public guile-websocket
-  (let ((commit "d17878f6c12c10a49196bb08f737f36b11e61c31")
-        (revision "1"))
-    (package
-      (name "guile-websocket")
-      (version (git-version "0.1" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://git.dthompson.us/guile-websocket.git")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "0kcmhjyb6amm4b9k4ng0r5s38m041mvh5jgmjbz6ichz39k255v7"))))
-      (build-system gnu-build-system)
-      (arguments
-       '(#:make-flags
-         '("GUILE_AUTO_COMPILE=0")))
-      (native-inputs
-       (list autoconf automake pkg-config))
-      (inputs
-       (list guile-3.0))
-      (synopsis "Websocket server/client for Guile")
-      (description "Guile-websocket provides an implementation of the
+  (package
+    (name "guile-websocket")
+    (version "0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://files.dthompson.us/guile-websocket/"
+                                  "guile-websocket-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0x2hw188kcg6zd6480dqfynfvzjgfp50kji4y4ql69mnf1jd6h94"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:make-flags
+       '("GUILE_AUTO_COMPILE=0")))
+    (native-inputs
+     (list autoconf automake pkg-config))
+    (inputs
+     (list guile-3.0))
+    (synopsis "Websocket server/client for Guile")
+    (description "Guile-websocket provides an implementation of the
 WebSocket protocol as defined by RFC 6455.")
-      (home-page "https://git.dthompson.us/guile-websocket.git")
-      (license license:lgpl3+))))
+    (home-page "https://dthompson.us/projects/guile-websocket.html")
+    (license license:lgpl3+)))
 
 (define-public guile-rdf
   (package