summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-08 22:05:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:35 +0100
commitc647bd42a3f7e03b1eb2e4d196c79de3be237f3b (patch)
tree6c75718a7319c3a5bd46af32d2662a1f4b167ff9 /gnu/packages
parent82b7c3077f3f7eb705432bfa1e7e03f863ee2872 (diff)
downloadguix-c647bd42a3f7e03b1eb2e4d196c79de3be237f3b.tar.gz
gnu: python-seaborn: Update to 0.13.1.
* gnu/packages/python-xyz.scm (python-seaborn): Update to 0.13.1.
[propagated-inputs]: Add python-ipykernel, python-mypy, python-nbconvert,
python-numpydoc, python-pyyaml, and python-statsmodels.
[native-inputs]: Add python-flake8, python-pre-commit, python-pytest-cov, and
python-pytest-xdist; remove python-pypa-build.

Change-Id: Id1ed6cfaf7e0950e99c06900fd68fb1ab884bee0
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 21 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 980fe08400..1964b8eb9f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -257,6 +257,7 @@
   #:use-module (gnu packages shells)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages ssh)
+  #:use-module (gnu packages statistics)
   #:use-module (gnu packages swig)
   #:use-module (gnu packages tcl)
   #:use-module (gnu packages terminals)
@@ -12576,17 +12577,32 @@ SVG, EPS, PNG and terminal output.")
 (define-public python-seaborn
   (package
     (name "python-seaborn")
-    (version "0.12.0")
+    (version "0.13.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "seaborn" version))
               (sha256
                (base32
-                "08vvnp4ps86857imxz2l5xi2vir5xdcdp3apq4badb4b5llifgw9"))))
+                "0ycibcs6kvd3xi4zsxna81claqifyb9dn6z6jwc5x7lqqplnbbdz"))))
     (build-system pyproject-build-system)
-    (propagated-inputs (list python-pandas python-matplotlib python-numpy
-                             python-scipy))
-    (native-inputs (list python-flit-core python-pypa-build python-pytest))
+    (propagated-inputs
+     (list python-ipykernel
+           python-matplotlib
+           python-mypy
+           python-nbconvert
+           python-numpy
+           python-numpydoc
+           python-pandas
+           python-pyyaml
+           python-scipy
+           python-statsmodels))
+    (native-inputs
+     (list python-flake8
+           python-flit-core
+           python-pre-commit
+           python-pytest
+           python-pytest-cov
+           python-pytest-xdist))
     (home-page "https://seaborn.pydata.org/")
     (synopsis "Statistical data visualization")
     (description