summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:28:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:53 +0200
commitc735e724b569430ab81bf37ed1f2eced539a0884 (patch)
tree337a8be748824dd24e9850702b9b37aa062b0807 /gnu/packages
parentf3e2b3da8fb5472d347276a2c13bde00583a9fee (diff)
downloadguix-c735e724b569430ab81bf37ed1f2eced539a0884.tar.gz
gnu: Add texlive-lplfitch.
* gnu/packages/tex.scm (texlive-lplfitch): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1536610527..8f98fea9d3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4432,6 +4432,28 @@ display any series of aligned equations with easy labeling/referencing and
 other customization options.")
     (license license:lppl)))
 
+(define-public texlive-lplfitch
+  (package
+    (name "texlive-lplfitch")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/lplfitch/"
+                   "source/latex/lplfitch/"
+                   "tex/latex/lplfitch/")
+             (base32
+              "1x396k71r8sb04pby3h6snjzmyzmai9s11icgxf1vi9dswh191cz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/lplfitch")
+    (synopsis "Fitch-style natural deduction proofs")
+    (description
+     "The package provides macros for typesetting natural deduction proofs in
+Fitch style, with subproofs indented and offset by scope lines.  The proofs
+from use of the package are in the format used in the textbook @emph{Language,
+Proof, and Logic} by Dave Barker-Plummer, Jon Barwise, and John Etchemendy.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")