summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-30 04:07:59 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-30 04:52:09 +0200
commitc8046d1b229f311ad28baa6250f7aadc84e7b2eb (patch)
tree8e6cbe34539aac46f39abc3a86e371196ead5838 /gnu/packages
parenta0484d9ff7866e469ae2044dc2d3fd4bd77ee4c2 (diff)
downloadguix-c8046d1b229f311ad28baa6250f7aadc84e7b2eb.tar.gz
gnu: scrypt: Update to 1.3.1.
* gnu/packages/crypto.scm (scrypt): Update to 1.3.1.
[arguments]: Patch configure to respect $PATH.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crypto.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index eb00326ad2..ae68a2992e 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -518,7 +518,7 @@ user's graphical desktop.")
 (define-public scrypt
   (package
     (name "scrypt")
-    (version "1.2.1")
+    (version "1.3.1")
     (source
       (origin
         (method url-fetch)
@@ -526,13 +526,16 @@ user's graphical desktop.")
                             version ".tgz"))
         (sha256
          (base32
-          "0xy5yhrwwv13skv9im9vm76rybh9f29j2dh4hlh2x01gvbkza8a6"))))
+          "1hnl0r6pmyxiy4dmafmqk1db7wpc0x9rqpzqcwr9d2cmghcj6byz"))))
     (build-system gnu-build-system)
     (arguments
      `(#:license-file-regexp "COPYRIGHT"
        #:phases (modify-phases %standard-phases
-        (add-after 'unpack 'patch-command-invocations
+        (add-after 'unpack 'patch-$PATH-assumptions
           (lambda _
+            (substitute* "configure"
+              (("\\{POSIX_PATH\\}")
+               "{PATH}"))
             (substitute* "Makefile.in"
               (("command -p") ""))
             #t))