summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-24 16:41:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:40 +0300
commitc89e95f5c60dcfdb49cae333118f6fc1f3bbff79 (patch)
treebca044e2aca6ce6badfd141ba1c00bff99fe886f /gnu/packages
parent3f9dfac5fa5d6f7f9d8dec329cf730c57b6c8435 (diff)
downloadguix-c89e95f5c60dcfdb49cae333118f6fc1f3bbff79.tar.gz
gnu: Add rust-owned-ttf-parser-0.19.
* gnu/packages/crates-io.scm (rust-owned-ttf-parser-0.19): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0cd59c364a..0d03c5c7b2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -41337,6 +41337,26 @@ platform-native strings.")
      "This package provides a macro to simplify operator overloading.")
     (license license:expat)))
 
+(define-public rust-owned-ttf-parser-0.19
+  (package
+    (name "rust-owned-ttf-parser")
+    (version "0.19.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "owned-ttf-parser" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "192v6mjgy2fv7z8n7wm6548pikngcc293l9qh8xdc4s147iffvbh"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-ttf-parser" ,rust-ttf-parser-0.19))))
+    (home-page "https://github.com/alexheretic/owned-ttf-parser")
+    (synopsis "Ttf-parser plus support for owned data")
+    (description
+     "This package provides a ttf-parser plus support for owned data.")
+    (license license:asl2.0)))
+
 (define-public rust-owned-ttf-parser-0.6
   (package
     (name "rust-owned-ttf-parser")