summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish.is@lostca.se>2024-08-14 17:44:34 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-08-15 14:23:39 +0200
commitc9dd09855e69af3e166ddfdafb3a1f57a26901e0 (patch)
treef301821503cf735620e198eb64c877ef2302938e /gnu/packages
parent5d1c3bad5c629f3fa588155e3afbf2b1cc9e8603 (diff)
downloadguix-c9dd09855e69af3e166ddfdafb3a1f57a26901e0.tar.gz
gnu: ccl: Update to 1.13.
* gnu/packages/lisp.scm (ccl): Update to 1.13.
  [inputs] Update ccl bootstrap sources.

Change-Id: Id2b9d29b4ea51aba23ca1aee770e33755b062b19
Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/lisp.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 97f7dd357b..b446dd8b56 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -230,7 +230,7 @@ integration with code written in C.")
     (name "ccl")
     ;; XXX When updating this package, check whether we can simply append
     ;; VERSION to the ccl-bootstrap URL again, instead of per architecture.
-    (version "1.12.1")
+    (version "1.13")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -239,7 +239,7 @@ integration with code written in C.")
               (file-name (git-file-name "ccl" version))
               (sha256
                (base32
-                "1zz291lvsrr7pps8wfl2kdxsnzjngqi4v3mil14pga4r5zanmsi7"))))
+                "12cb3gp43bhl7nyms3a4lix8j1s3arnp124d3ahc2lhlrjirs0mr"))))
     (build-system gnu-build-system)
     ;; CCL consists of a "lisp kernel" and "heap image", both of which are
     ;; shipped in precompiled form in source tarballs.  The former is a C
@@ -253,18 +253,18 @@ integration with code written in C.")
            (uri (string-append
                  "https://github.com/Clozure/ccl/releases/download/v"
                  (match (%current-system)
-                   ("armhf-linux" "1.12/linuxarm")
+                   ("armhf-linux" "1.13/linuxarm")
                    ;; XXX: This source only works on x86, but provide it as a
                    ;; catch-all to prevent errors when querying this package
                    ;; on unsupported platforms.
-                   (_ "1.12.1/linuxx86"))
+                   (_ "1.13/linuxx86"))
                  ".tar.gz"))
            (sha256
             (base32
              (match (%current-system)
                ("armhf-linux"
-                "0x4bjx6cxsjvxyagijhlvmc7jkyxifdvz5q5zvz37028va65243c")
-               (_ "0ll017ajcfsyx8f7zsy4394y8xxvz40iz0gcsmznp0n3mf0xi67c"))))))))
+                "1mlj7lgn4p9bw1ki7gk00sj89cjv0cjpdmpp65brhx9q3fvkk9xf")
+               (_ "04ry8zwrcjjmzbxp43nkknchabk6i6mclrzg5biwfp1h64bcnzfx"))))))))
     (native-inputs
      (list cl-asdf m4))
     (arguments