summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-02-10 10:14:48 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-02-10 11:21:21 +0100
commitca4c9062c4a04a3550fdcf67cb2b41daa13627d8 (patch)
tree4f962729ec951478df8f7bb5321d4b08077cac5e /gnu/packages
parenta303cb9a20030433519e254c5396b4d3e29dba5f (diff)
downloadguix-ca4c9062c4a04a3550fdcf67cb2b41daa13627d8.tar.gz
gnu: Add python-pdbfixer.
* gnu/packages/bioinformatics.scm (python-pdbfixer): New variable.

Change-Id: I2894a08ab3eed463f052b9df6372d4016b718d1a
Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4db6987763..554df0b42f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2244,6 +2244,38 @@ parallel.  It uses Python's native multiprocessing framework to apply a user
 defined rule on an input file.")
     (license license:gpl3)))
 
+(define-public python-pdbfixer
+  (package
+    (name "python-pdbfixer")
+    (version "1.9")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/openmm/pdbfixer")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1zjhb19q5dclkwvzh8n29p31n1vzkhlmmzwqllimi89jsis1cx35"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      '(list "-k"
+             ;; These tests fail because they require internet access.
+             (string-append "not test_build_and_simulate.py"
+                            " and not test_cli.py"
+                            " and not test_mutate.py"))))
+    (propagated-inputs (list openmm python-numpy))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/openmm/pdbfixer")
+    (synopsis "Application for fixing problems in Protein Data Bank")
+    (description
+     "PDBFixer is designed to rectify issues in Protein Data Bank files.
+Its intuitive interface simplifies the process of resolving problems
+encountered in PDB files prior to simulation tasks.")
+    (license license:expat)))
+
 (define-public python-peaks2utr
   (package
     (name "python-peaks2utr")