summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-05 17:55:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-05 17:55:17 +0100
commitcb15b360aabb9a572dd8f4a697e50cba4481902e (patch)
treea3e1c91822668c3248d118f40c7355e38dddd175 /gnu/packages
parent41f0de65b498477da0783a69226dfa92848897ad (diff)
downloadguix-cb15b360aabb9a572dd8f4a697e50cba4481902e.tar.gz
gnu: Add python-snaptools.
* gnu/packages/bioinformatics.scm (python-snaptools): New variable.

Change-Id: I4f4b32cbbb64472e65d2d88184173b6e1a75e8d2
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioinformatics.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4bed2e4fe8..a363298386 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2366,6 +2366,40 @@ sequencing data and the end result are tables of UMI-unique DamID and CEL-Seq
 counts.")
     (license license:expat)))
 
+(define-public python-snaptools
+  (package
+    (name "python-snaptools")
+    (version "1.4.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "snaptools" version))
+       (sha256
+        (base32
+         "1s5373g5jjbshh3q39zy7dlxr7nda6ksxq9d1gw46h82c4fsmfbn"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs
+     (list python-future
+           python-h5py
+           python-louvain
+           python-numpy
+           python-pybedtools
+           python-pysam))
+    (home-page "https://github.com/r3fang/SnapTools")
+    (synopsis "Tools for processing snap files" )
+    (description
+     "@code{SnapTools} can operate on snap files the following types of
+operations:
+
+@itemize
+@item index the reference genome before alignment;
+@item align reads to the corresponding reference genome;
+@item pre-process by convert pair-end reads into fragments, checking the
+  mapping quality score, alingment and filtration;
+@item create the cell-by-bin matrix.
+@end itemize")
+    (license license:asl2.0)))
+
 (define-public python-bioframe
   (package
     (name "python-bioframe")