summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-07-04 13:20:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-04 13:48:57 +0200
commitcbfcff596120084b584fcab29c19d57c3a871dd3 (patch)
tree04e9923a839af7465f9c83a219d6764fbddd2c9d /gnu/packages
parent4aee04819e98d1fecf8b0d3c59d2c34f47bad2c5 (diff)
downloadguix-cbfcff596120084b584fcab29c19d57c3a871dd3.tar.gz
gnu: Add r-ggrastr.
* gnu/packages/cran.scm (r-ggrastr): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 57c2ae5d15..1e93e14ac1 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1005,6 +1005,29 @@ variables.")
 ")
     (license license:gpl2+)))
 
+(define-public r-ggrastr
+  (package
+    (name "r-ggrastr")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "ggrastr" version))
+              (sha256
+               (base32
+                "07sx5wlawfyb0zy5am2q1ajhkdym5r9ih47p57l8bv4dlc7ykml2"))))
+    (properties `((upstream-name . "ggrastr")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-cairo r-ggbeeswarm r-ggplot2 r-png r-ragg))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/VPetukhov/ggrastr")
+    (synopsis "Rasterize layers for ggplot2")
+    (description
+     "Rasterize only specific layers of a ggplot2 plot while simultaneously keeping
+all labels and text in vector format.  This allows users to keep plots within
+the reasonable size limit without losing vector properties of the
+scale-sensitive information.")
+    (license license:expat)))
+
 (define-public r-lmds
   (package
     (name "r-lmds")