summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authoraltadil <Altadil@protonmail.com>2023-08-22 19:35:07 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-05 19:50:43 -0400
commitcc3fbfbb21dd6540a0db6cec116fe17d7b1c6241 (patch)
treed1d0e9da20f77bc8ff465369efbd52ac570df289 /gnu/packages
parent3d351a631bcbf3fc3d072cb9395ef4b1ceb16b3d (diff)
downloadguix-cc3fbfbb21dd6540a0db6cec116fe17d7b1c6241.tar.gz
gnu: granite: Upgrade to 7.3.0.
* gnu/packages/pantheon.scm (granite): Upgrade to 7.3.0.
[inputs]: Remove gtk+.  Add sassc.  Move glib and libgee to...
[propagated-inputs]: ... here.  Add gtk.
[native-inputs]: Add glib:bin.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/pantheon.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 1c6795cc1d..5083eb99cd 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -30,6 +30,7 @@
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages xml)
+  #:use-module (gnu packages web)
   #:use-module (gnu packages)
   #:use-module (guix build-system meson)
   #:use-module (guix git-download)
@@ -40,7 +41,7 @@
 (define-public granite
   (package
     (name "granite")
-    (version "6.2.0")
+    (version "7.3.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -49,16 +50,21 @@
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0ilslmg63hh2x7h5rvs3mhzw1y9ixhhkqnn1j1lzwm12v2iidkaq"))))
+                "0pyvkif2kin5dskh7adadsh4r96mvx12y7cs6gnm0ml733q548dj"))))
     (build-system meson-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-after 'unpack 'disable-icon-cache
                     (lambda _
                       (setenv "DESTDIR" "/"))))))
-    (inputs (list glib gtk+ libgee))
-    (native-inputs (list gettext-minimal gobject-introspection pkg-config
-                         python vala))
+    (inputs (list sassc))
+    (propagated-inputs (list glib libgee gtk))      ;required in .pc file
+    (native-inputs (list gettext-minimal
+                         `(,glib "bin")
+                         gobject-introspection
+                         pkg-config
+                         python
+                         vala))
     (home-page "https://github.com/elementary/granite")
     (synopsis "Library that extends GTK with common widgets and utilities")
     (description "Granite is a companion library for GTK+ and GLib.  Among other