summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:24:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:49:32 +0200
commitd26e61638162b329bb2d37d3ffd9eebe7f410777 (patch)
treeddad767468e97bc526fe2dbab6eac0e91f951c9e /gnu/packages
parent80bfe3a740cb90c61c054a5bf87ff8c0f0657253 (diff)
downloadguix-d26e61638162b329bb2d37d3ffd9eebe7f410777.tar.gz
gnu: Add texlive-sudoku.
* gnu/packages/tex.scm (texlive-sudoku): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 37dd86449b..595e692164 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13725,6 +13725,25 @@ mode by providing an optional argument to @samp{_}.  This is implemented by
 using the @code{\\text@{@}} command from the @code{amstext} package.")
     (license license:gpl3)))
 
+(define-public texlive-sudoku
+  (package
+    (name "texlive-sudoku")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/sudoku/" "source/latex/sudoku/"
+                   "tex/latex/sudoku/")
+             (base32
+              "14g1kkxinp9l57yvdpbdx4wclgka71gilcbxl1dc6sdj4cmw7mbz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/sudoku")
+    (synopsis "Create sudoku grids")
+    (description
+     "The @code{sudoku} package provides an environment for typesetting sudoku
+grids.")
+    (license license:lppl)))
+
 (define-public texlive-susy
   (package
     (name "texlive-susy")