summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-12-18 18:37:11 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-12-18 18:43:29 -0500
commitd55a4431f3d2b2d61a5b505a8cbbb4cbbd7a8090 (patch)
tree39d40b044d7a12b8fae4a5411e81b9cc6a6aa327 /gnu/packages
parent1b0e216ad68cf5a893d4007d1373cdc30c820df6 (diff)
downloadguix-d55a4431f3d2b2d61a5b505a8cbbb4cbbd7a8090.tar.gz
gnu: gtk: Skip failing test.
The 'gtk:tools / validate' test started failing for unknown reasons after
updating mesa to 23.3.1 and xorgproto to 2023.2. Skip for now.

* gnu/packages/gtk.scm (gtk)[arguments]{phases}: Skip the 'gtk:tools /
validate' test using the 'patch' phase.

Change-Id: I7d0a459c0cbbb979f4589f929eb637f00f642225
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index cc33c9f672..1a3bb56945 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1178,7 +1178,11 @@ application suites.")
                 ;; The unaligned-offscreen test fails for unknown reasons, also
                 ;; on different distributions (see:
                 ;; https://gitlab.gnome.org/GNOME/gtk/-/issues/4889).
-                (("  'unaligned-offscreen',") ""))
+                (("  'unaligned-offscreen',") "")
+                ;; This test, 'gtk:tools / validate', started failing for
+                ;; unknown reasons after updating mesa to 23.3.1 and xorgproto
+                ;; to 2023.2.
+                ((" 'validate',") ""))
               (substitute* "testsuite/reftests/meson.build"
                 (("[ \t]*'label-wrap-justify.ui',") "")
                 ;; The inscription-markup.ui fails due to /etc/machine-id