summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-01-27 19:21:28 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-31 21:20:17 +0000
commitd6410c5c47011f53e3bf0cc3218201720bd81f22 (patch)
tree823ef281fe7fe8db8df09add44b9a25668c89e77 /gnu/packages
parent6d5fe89e8ef385485ee84ceae178be8e7135fa7c (diff)
downloadguix-d6410c5c47011f53e3bf0cc3218201720bd81f22.tar.gz
gnu: Add go-staticcheck.
* gnu/packages/golang-check.scm (go-staticcheck): New variable.

Change-Id: I82ce27df1bdbd79ae4740928e0661b585289d02b
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-check.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index ae496affd0..262048a235 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -96,6 +96,21 @@ simplifications, and enforces style rules.")
     (description "This package turns unkeyed struct literals (@code{T{1, 2,
 3}}) into keyed ones (@code{T{A: 1, B: 2, C: 3}}) in Go.")))
 
+(define-public go-staticcheck
+  (package
+    (inherit go-honnef-co-go-tools)
+    (name "go-staticcheck")
+    (arguments
+     `(#:go ,go-1.18
+       #:import-path "honnef.co/go/tools/cmd/staticcheck"
+       #:unpack-path "honnef.co/go/tools"
+       #:install-source? #f))
+    (synopsis "Staticcheck advanced Go linter")
+    (description
+     "Staticcheck is a state of the art linter for the Go programming language.
+Using static analysis, it finds bugs and performance issues, offers
+simplifications, and enforces style rules.")))
+
 (define-public go-github-com-alecthomas-assert
   (let ((commit "405dbfeb8e38effee6e723317226e93fff912d06")
         (revision "1"))